#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#\[\[(?<name>.+?)\]\]"
Local $sString = "my first tag is #[[1:hashTag:Rameez]] and second tag is #[[2:hashTag:Rameez2]]." & @CRLF & _
"Did I forget to mention that last tag is #[[3:hashTag:Rameez2]]?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")