package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#\[\[(?<name>.+?)\]\]`)
var str = `my first tag is #[[1:hashTag:Rameez]] and second tag is #[[2:hashTag:Rameez2]].
Did I forget to mention that last tag is #[[3:hashTag:Rameez2]]?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}