const regex = /\[link\](.*)\[\/link\]/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[link\\](.*)\\[\\\/link\\]', 'si')
const str = `valami [link]link egy[/link] még valami [link]link 2[/link]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}