re = /\[link\](.*)\[\/link\]/i
str = 'valami [link]link egy[/link] még valami [link]link 2[/link]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end