$re = '/\[link\](.*)\[\/link\]/Dsi';
$str = 'valami [link]link egy[/link] még valami [link]link 2[/link]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);