const regex = /^.*\bjson\b(?:(?!\bfrom\b).)+\bjson\b.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\bjson\\b(?:(?!\\bfrom\\b).)+\\bjson\\b.*$', 'gm')
const str = `select json,json from XXX
select json from json XXXX
select json,json from json XXX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}