$re = '/^.*\bjson\b(?:(?!\bfrom\b).)+\bjson\b.*$/m';
$str = 'select json,json from XXX
select json from json XXXX
select json,json from json XXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);