re = /^.*\bjson\b(?:(?!\bfrom\b).)+\bjson\b.*$/m
str = 'select json,json from XXX
select json from json XXXX
select json,json from json XXX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end