const regex = /(?<=https:\/\/).*?(?=\/wp-content)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=https:\\\/\\\/).*?(?=\\\/wp-content)', 'gm')
const str = `<img src="https://domain-to-replace.com/wp-content/uploads/2023/03/dark-academia-300-vintage-ephemera-1-299x199.jpeg" alt="Dark Academia: 300 Vintage Ephemera" srcset="https://domain-to-replace.com/wp-content/uploads/2023/03/dark-academia-300-vintage-ephemera-1-299x199.jpeg 1x,https://domain-to-replace.com/wp-content/uploads/2023/03/1ff9XNiP-dark-academia-300-vintage-ephemera-1-600x400.jpeg 2x,https://domain-to-replace.com/wp-content/uploads/2023/03/1ff9XNiP-dark-academia-300-vintage-ephemera-1-600x400.jpeg 3x" class="lazyloaded" data-ll-status="loaded">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}