$re = '/(?<=https:\/\/).*?(?=\/wp-content)/m';
$str = '<img src="https://domain-to-replace.com/wp-content/uploads/2023/03/dark-academia-300-vintage-ephemera-1-299x199.jpeg" alt="Dark Academia: 300 Vintage Ephemera" srcset="https://domain-to-replace.com/wp-content/uploads/2023/03/dark-academia-300-vintage-ephemera-1-299x199.jpeg 1x,https://domain-to-replace.com/wp-content/uploads/2023/03/1ff9XNiP-dark-academia-300-vintage-ephemera-1-600x400.jpeg 2x,https://domain-to-replace.com/wp-content/uploads/2023/03/1ff9XNiP-dark-academia-300-vintage-ephemera-1-600x400.jpeg 3x" class="lazyloaded" data-ll-status="loaded">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);