import Foundation
let pattern = #"(?<=https:\/\/).*?(?=\/wp-content)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<img src="https://domain-to-replace.com/wp-content/uploads/2023/03/dark-academia-300-vintage-ephemera-1-299x199.jpeg" alt="Dark Academia: 300 Vintage Ephemera" srcset="https://domain-to-replace.com/wp-content/uploads/2023/03/dark-academia-300-vintage-ephemera-1-299x199.jpeg 1x,https://domain-to-replace.com/wp-content/uploads/2023/03/1ff9XNiP-dark-academia-300-vintage-ephemera-1-600x400.jpeg 2x,https://domain-to-replace.com/wp-content/uploads/2023/03/1ff9XNiP-dark-academia-300-vintage-ephemera-1-600x400.jpeg 3x" class="lazyloaded" data-ll-status="loaded">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)