using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|,\s?)(?:(?<name>[A-Z]+)=(?<val>""(?:[^""]|"")+""|[^,]+))+";
string input = @"O=""Acme Stuff, and ""More"" Stuff"", OU=Stuff, E=""stuff@acme.com"", CN=""My CN, with a comma ""and quotes!""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}