package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|,\s?)(?:(?<name>[A-Z]+)=(?<val>"(?:[^"]|"")+"|[^,]+))+`)
var str = `O="Acme Stuff, and ""More"" Stuff", OU=Stuff, E="stuff@acme.com", CN="My CN, with a comma ""and quotes!"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}