re = /(?:^|,\s?)(?:(?<name>[A-Z]+)=(?<val>"(?:[^"]|"")+"|[^,]+))+/
str = 'O="Acme Stuff, and ""More"" Stuff", OU=Stuff, E="stuff@acme.com", CN="My CN, with a comma ""and quotes!"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end