import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:Length|Width|Height|Weight) (?:\\.\\d{1,2}|\\d{1,4}\\.?\\d{0,2}|\\d{5}\\.?\\d?|\\d{6}\\.?) (?:in|oz|lbs|VAC|Hz|amps|H\\.P\\.|kg)(?!\\S)";
final String string = "Width 3.5 in\n"
+ "Weight 10 kg\n"
+ "Weight 10 H.P.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}