re = /\b(?:Length|Width|Height|Weight) (?:\.\d{1,2}|\d{1,4}\.?\d{0,2}|\d{5}\.?\d?|\d{6}\.?) (?:in|oz|lbs|VAC|Hz|amps|H\.P\.|kg)(?!\S)/mi
str = 'Width 3.5 in
Weight 10 kg
Weight 10 H.P.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end