const regex = new RegExp('\\b(?:Length|Width|Height|Weight) (?:\\.\\d{1,2}|\\d{1,4}\\.?\\d{0,2}|\\d{5}\\.?\\d?|\\d{6}\\.?) (?:in|oz|lbs|VAC|Hz|amps|H\\.P\\.|kg)(?!\\S)', 'gmi')
const str = `Width 3.5 in
Weight 10 kg
Weight 10 H.P.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}