package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(www\.)*(?P<secure_domain>([-0-9a-z]+\.)?[-0-9a-z]+\.[a-z]+)$`)
var str = `www.domain.com
domain.com
www.sub1.domain.com
sub1.domain.com
www.sub2.sub1.domain.com
sub2.sub1.domain.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}