re = /(www\.)*(?P<secure_domain>([-0-9a-z]+\.)?[-0-9a-z]+\.[a-z]+)$/m
str = 'www.domain.com
domain.com
www.sub1.domain.com
sub1.domain.com
www.sub2.sub1.domain.com
sub2.sub1.domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end