const regex = /(www\.)*(?P<secure_domain>([-0-9a-z]+\.)?[-0-9a-z]+\.[a-z]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(www\\.)*(?P<secure_domain>([-0-9a-z]+\\.)?[-0-9a-z]+\\.[a-z]+)$', 'gm')
const str = `www.domain.com
domain.com
www.sub1.domain.com
sub1.domain.com
www.sub2.sub1.domain.com
sub2.sub1.domain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}