package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^ ]+$`)
var str = `Some description about something: the-value-I-want-separated-by-hyphens`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}