$re = '/[^ ]+$/m';
$str = 'Some description about something: the-value-I-want-separated-by-hyphens';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);