re = /[^ ]+$/m
str = 'Some description about something: the-value-I-want-separated-by-hyphens'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end