#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\")((?:\\\"|[^"\t\r\n])+(?:\t(?!\"))?(?:\\\"|[^"\t\r\n])*)(?=\")"
Local $sString = " "parent key 1" "parent value1"" & @CRLF & _
" {" & @CRLF & _
" "child key 1" "child value 1"" & @CRLF & _
" "child key 2" "child value 2"" & @CRLF & _
" }" & @CRLF & _
" "parent key 2" "parent Value2"" & @CRLF & _
" "parent key 3"" & @CRLF & _
" "parent key 4"" & @CRLF & _
" {" & @CRLF & _
" "child key 3" "3 with \"escaped quotes\" inside that should be included"" & @CRLF & _
" "child key 4" "4 a tab inside that should be included"" & @CRLF & _
" "child key 5" "5 escaped quote at the end which shouldn't create an empty match\""" & @CRLF & _
" "child key 6" "6"" & @CRLF & _
" "child key 7" """ & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")