import Foundation
let pattern = #"(?<=\")((?:\\\"|[^"\t\r\n])+(?:\t(?!\"))?(?:\\\"|[^"\t\r\n])*)(?=\")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"parent key 1" "parent value1"
{
"child key 1" "child value 1"
"child key 2" "child value 2"
}
"parent key 2" "parent Value2"
"parent key 3"
"parent key 4"
{
"child key 3" "3 with \"escaped quotes\" inside that should be included"
"child key 4" "4 a tab inside that should be included"
"child key 5" "5 escaped quote at the end which shouldn't create an empty match\""
"child key 6" "6"
"child key 7" ""
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)