$re = '/(?<=\")((?:\\\\\"|[^"\t\r\n])+(?:\t(?!\"))?(?:\\\\\"|[^"\t\r\n])*)(?=\")/m';
$str = ' "parent key 1" "parent value1"
{
"child key 1" "child value 1"
"child key 2" "child value 2"
}
"parent key 2" "parent Value2"
"parent key 3"
"parent key 4"
{
"child key 3" "3 with \\"escaped quotes\\" inside that should be included"
"child key 4" "4 a tab inside that should be included"
"child key 5" "5 escaped quote at the end which shouldn\'t create an empty match\\""
"child key 6" "6"
"child key 7" ""
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);