use strict;
my $str = 'function(data, x = !!rlang::sym("Time1"), y = !!rlang::sym("YVAR")), values = c("a", "b"))';
my $regex = qr/!!rlang::sym\(\"([\w\W]*?)"\)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";