re = /!!rlang::sym\(\"([\w\W]*?)"\)/m
str = 'function(data, x = !!rlang::sym("Time1"), y = !!rlang::sym("YVAR")), values = c("a", "b"))'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result