$re = '/!!rlang::sym\(\"([\w\W]*?)"\)/m';
$str = 'function(data, x = !!rlang::sym("Time1"), y = !!rlang::sym("YVAR")), values = c("a", "b"))';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;