import re
regex = re.compile(r"(?<=[a-z]{2})lah", flags=re.MULTILINE)
test_str = ("blah blah blah jnfskjndflah\n"
"jnfskjndflah\n"
"blah")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)