re = /(?<=[a-z]{2})lah/m
str = 'blah blah blah jnfskjndflah
jnfskjndflah
blah'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result