const regex = new RegExp('(?<!\\S)(?=(?:[^.]|\\.(?=\\d))*\\bapple\\b)(?:[^.]|\\.(?=\\d))*\\bcosts\\b(?:[^.]|\\.(?=\\d))*\\.', 'gm')
const str = `Supermarket. This apple costs 0.99.
Supermarket. This costs apple 0.99.
Monday evening. Supermarket. This apple costs 0.99. Too expensive.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}