import re
regex = re.compile(r"(?<!\S)(?=(?:[^.]|\.(?=\d))*\bapple\b)(?:[^.]|\.(?=\d))*\bcosts\b(?:[^.]|\.(?=\d))*\.", flags=re.MULTILINE)
test_str = ("Supermarket. This apple costs 0.99.\n"
"Supermarket. This costs apple 0.99.\n"
"Monday evening. Supermarket. This apple costs 0.99. Too expensive.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")