$re = '/(?<!\S)(?=(?:[^.]|\.(?=\d))*\bapple\b)(?:[^.]|\.(?=\d))*\bcosts\b(?:[^.]|\.(?=\d))*\./m';
$str = 'Supermarket. This apple costs 0.99.
Supermarket. This costs apple 0.99.
Monday evening. Supermarket. This apple costs 0.99. Too expensive.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);