const regex = /^(?#at least one capital letter)(?=.*?[A-Z])(?#at leaste one lower case letter)(?=(.*[a-z]))(?#at leaste one number)(?=(.*[\d]))(?#at leaste one non letter or number)(?=(.*[^a-zA-Z0-9])).{6,}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?#at least one capital letter)(?=.*?[A-Z])(?#at leaste one lower case letter)(?=(.*[a-z]))(?#at leaste one number)(?=(.*[\\d]))(?#at leaste one non letter or number)(?=(.*[^a-zA-Z0-9])).{6,}$', 'g')
const str = `Ik gebruik altijd een zin als w8woord`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}