import re
regex = re.compile(r"^(?#at least one capital letter)(?=.*?[A-Z])(?#at leaste one lower case letter)(?=(.*[a-z]))(?#at leaste one number)(?=(.*[\d]))(?#at leaste one non letter or number)(?=(.*[^a-zA-Z0-9])).{6,}$")
test_str = "Ik gebruik altijd een zin als w8woord"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")