re = /^(?#at least one capital letter)(?=.*?[A-Z])(?#at leaste one lower case letter)(?=(.*[a-z]))(?#at leaste one number)(?=(.*[\d]))(?#at leaste one non letter or number)(?=(.*[^a-zA-Z0-9])).{6,}$/
str = 'Ik gebruik altijd een zin als w8woord'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end