using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(\/| |^)r *\/ *(?!(superstonk( |$|\/)|gme( |$|\/)|all( |$|\/)))\w*(\?|\/|\.| |$|!)";
string input = @"r/all
r/ALL
r
r/superstonk
R/SUPERSTONK
Word r/superstonk
word r/superstonk word
r/superstonk?
r/superstonk.
r/superstonk!
r/superstonk
r /superstonk
https://www.reddit.com/r/Superstonk?utm_medium=android_app&utm_source=share
r/random
R/RANDOM
Word r/random
word r/random word
r/random?
r/superstonk.
r/random!
r/random
r /random
https://www.reddit.com/r/random?utm_medium=android_app&utm_source=share
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}