import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(\\/| |^)r *\\/ *(?!(superstonk( |$|\\/)|gme( |$|\\/)|all( |$|\\/)))\\w*(\\?|\\/|\\.| |$|!)";
final String string = "r/all\n"
+ "r/ALL\n\n"
+ "r \n\n"
+ "r/superstonk\n"
+ "R/SUPERSTONK\n"
+ "Word r/superstonk\n"
+ "word r/superstonk word\n"
+ "r/superstonk?\n"
+ "r/superstonk.\n"
+ "r/superstonk!\n"
+ "r/superstonk \n"
+ "r /superstonk\n"
+ "https://www.reddit.com/r/Superstonk?utm_medium=android_app&utm_source=share\n\n\n\n"
+ "r/random\n"
+ "R/RANDOM\n"
+ "Word r/random\n"
+ "word r/random word\n"
+ "r/random?\n"
+ "r/superstonk.\n"
+ "r/random!\n"
+ "r/random \n"
+ "r /random \n"
+ "https://www.reddit.com/r/random?utm_medium=android_app&utm_source=share\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}