#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])(?=[^\d!@#\$%\^&]*[^\d!@#\$%\^&]).{8,16}$"
Local $sString = "Tester01" & @CRLF & _
"Tester0%" & @CRLF & _
"Tester%$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")