re = /^(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])(?=[^\d!@#\$%\^&]*[^\d!@#\$%\^&]).{8,16}$/m
str = 'Tester01
Tester0%
Tester%$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end