$re = '/^(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])(?=[^\d!@#\$%\^&]*[^\d!@#\$%\^&]).{8,16}$/m';
$str = 'Tester01
Tester0%
Tester%$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);