const regex = /^[a-zA-z:\/0-9]+\.[a-zA-z0-9\-].+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-z:\\\/0-9]+\\.[a-zA-z0-9\\-].+', 'gm')
const str = `http://wwwgooglees.com
pepe.es
ALOnso.es.ese.eso.shda;lsd.sadfaw
g.co
123Ahsplas.edu.gAva.essssss
sergicampos112.com
https://rexex101.com
como maximo 127 dominios
nombre de dominio 253 char
cada level name maximo 63 char
level names lowercase uppercase, ascii,digitos y signo menos pero no puede empezar ni acabar en simbolo menos
top level no puede ser todo numeros`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}