#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<branch>(?:(?<prefix>.*)\/)?(?<suffix>(?:(?:(?<issue>[A-Za-z0-9-]*-\d*)-)?(?<slug>.*))))"
Local $sString = "JIRA-1234-testing-node" & @CRLF & _
"JIRA-1234" & @CRLF & _
"feature/JIRA-1234-testing-node" & @CRLF & _
"bugfix/JIRA5-1234-testing-node" & @CRLF & _
"feature/jira-1234-testing-node" & @CRLF & _
"bugfix/JIRA-1234-testing-node" & @CRLF & _
"release/JIRA-1234-testing-node" & @CRLF & _
"hotfix/JIRA-1234-testing-node" & @CRLF & _
"TEST-TEST/JIRA-1234-testing-node-test" & @CRLF & _
"TEST-1234/JIRA-1234-testing-node_test" & @CRLF & _
"release/v1.0.1" & @CRLF & _
"release/v1.0.1-alpha" & @CRLF & _
"release/v1.0.1-alpha.0" & @CRLF & _
"release/v1.0.1-alpha,16" & @CRLF & _
"release/1.0.1" & @CRLF & _
"release/alpha" & @CRLF & _
"release/beta" & @CRLF & _
"release/latest" & @CRLF & _
"release/next" & @CRLF & _
"release/experimental" & @CRLF & _
"testing-node" & @CRLF & _
"experimenta" & @CRLF & _
"release-v1.6.1-test" & @CRLF & _
"staging" & @CRLF & _
"master" & @CRLF & _
"develope" & @CRLF & _
"release"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")