import Foundation
let pattern = #"(?<branch>(?:(?<prefix>.*)\/)?(?<suffix>(?:(?:(?<issue>[A-Za-z0-9-]*-\d*)-)?(?<slug>.*))))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
JIRA-1234-testing-node
JIRA-1234
feature/JIRA-1234-testing-node
bugfix/JIRA5-1234-testing-node
feature/jira-1234-testing-node
bugfix/JIRA-1234-testing-node
release/JIRA-1234-testing-node
hotfix/JIRA-1234-testing-node
TEST-TEST/JIRA-1234-testing-node-test
TEST-1234/JIRA-1234-testing-node_test
release/v1.0.1
release/v1.0.1-alpha
release/v1.0.1-alpha.0
release/v1.0.1-alpha,16
release/1.0.1
release/alpha
release/beta
release/latest
release/next
release/experimental
testing-node
experimenta
release-v1.6.1-test
staging
master
develope
release
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)