#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:_?[a-zA-Z0-9]+)*_?$"
Local $sString = "H_i_there" & @CRLF & _
"_this_is_OK_" & @CRLF & _
"_x_y_5_z" & @CRLF & _
"abddd_cdxxx" & @CRLF & _
"Not accepted:" & @CRLF & _
"" & @CRLF & _
"s___2" & @CRLF & _
"__s__t__2" & @CRLF & _
"__x____x4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")