use strict;
my $str = 'H_i_there
_this_is_OK_
_x_y_5_z
abddd_cdxxx
Not accepted:
s___2
__s__t__2
__x____x4';
my $regex = qr/^(?:_?[a-zA-Z0-9]+)*_?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}