package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:_?[a-zA-Z0-9]+)*_?$`)
var str = `H_i_there
_this_is_OK_
_x_y_5_z
abddd_cdxxx
Not accepted:
s___2
__s__t__2
__x____x4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}