import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?=(\\/)|(.html))";
final String string = "http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/\n\n\n"
+ "https://forums.questionablecontent.net/index.php/board,1.50.html\n\n\n"
+ "https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}