re = /\d+(?=(\/)|(.html))/
str = 'http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/
https://forums.questionablecontent.net/index.php/board,1.50.html
https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end